Libraries 2.x had a stable release just a few weeks ago so colorbox no longer needs to specify the dev version as mandatory.
My understanding is that the line "dependencies = libraries (2.x)" sets the dependency för Libraries API module version 2.x, i.e. 2.0 2.1 2.2 etc are ok but 1.0 or 1.1 etc are not.
This will then force people that use Colorbox 2.x to install or upgrade to Libraries 2.x.
That didn't appear to be the case for me. I have Libraries 7.x-2.1 and it wouldn't let me install colorbox.
But according to the documentation here, it _should_ work just fine:http://drupal.org/node/542202
If the bug is not reproducible it must be something particular to just this site.
Do you have this information in the libraries.info file?
; Information added by drupal.org packaging script on 2013-03-09version = "7.x-2.1"core = "7.x"project = "libraries"datestamp = "1362848412"
If you use git e.g. to install modules I believe this information is missing.
That is exactly what I have:
name = Librariesdescription = Allows version-dependent and shared usage of external libraries.core = 7.xfiles = tests/libraries.test; Information added by drupal.org packaging script on 2013-03-09version = "7.x-2.1"core = "7.x"project = "libraries"datestamp = "1362848412"
Putting this on hold unless someone else can reproduce.
It needs to read :
dependencies = libraries (>=2.0)
Marked #1859806: Enabling with drush causes "Module colorbox cannot be enabled because it depends on libraries (2.x) but 7.x-2.0 is available" as duplicate.
Issue #1953316 by dalin, griz: Update dependency version check for...
Unable to reproduce this but the "libraries (>=2.x)" format works equally well for me so committing.
Automatically closed - issue fixed for 2 weeks with no activity.
This issue has no child issues.
Drupal is a registered trademark of Dries Buytaert.