Libraries 2.x had a stable release just a few weeks ago so colorbox no longer needs to specify the dev version as mandatory.

Files: 
CommentFileSizeAuthor
#9 libraries_version_dependacy_fix-1953316-9.patch350 bytesgriz
PASSED: [[SimpleTest]]: [MySQL] 0 pass(es).
[ View ]
#1 1953316-1-colorbox_libraries_stable.patch342 bytesdalin
PASSED: [[SimpleTest]]: [MySQL] 0 pass(es).
[ View ]

Comments

dalin’s picture

Assigned:dalin» Unassigned
Category:task» feature
Status:Active» Needs review
StatusFileSize
new342 bytes
PASSED: [[SimpleTest]]: [MySQL] 0 pass(es).
[ View ]
frjo’s picture

My understanding is that the line "dependencies[] = libraries (2.x)" sets the dependency för Libraries API module version 2.x, i.e. 2.0 2.1 2.2 etc are ok but 1.0 or 1.1 etc are not.

This will then force people that use Colorbox 2.x to install or upgrade to Libraries 2.x.

dalin’s picture

That didn't appear to be the case for me. I have Libraries 7.x-2.1 and it wouldn't let me install colorbox.
But according to the documentation here, it _should_ work just fine:
http://drupal.org/node/542202
If the bug is not reproducible it must be something particular to just this site.

frjo’s picture

Do you have this information in the libraries.info file?

; Information added by drupal.org packaging script on 2013-03-09
version = "7.x-2.1"
core = "7.x"
project = "libraries"
datestamp = "1362848412"

If you use git e.g. to install modules I believe this information is missing.

dalin’s picture

Status:Needs review» Postponed

That is exactly what I have:

name = Libraries
description = Allows version-dependent and shared usage of external libraries.
core = 7.x
files[] = tests/libraries.test

; Information added by drupal.org packaging script on 2013-03-09
version = "7.x-2.1"
core = "7.x"
project = "libraries"
datestamp = "1362848412"

Putting this on hold unless someone else can reproduce.

griz’s picture

Issue summary:View changes

It needs to read :

dependencies[] = libraries (>=2.0)

https://drupal.org/node/1971694

dooug’s picture

Category:Feature request» Bug report
Status:Postponed» Needs work
griz’s picture

Status:Needs work» Needs review

Nudge :)

griz’s picture

StatusFileSize
new350 bytes
PASSED: [[SimpleTest]]: [MySQL] 0 pass(es).
[ View ]
frjo’s picture

Title:dev version of Libraries module no longer needed» Update dependency version check for libraries in info file
Status:Needs review» Fixed

  • frjo committed 5cf66da on 7.x-2.x authored by griz
    Issue #1953316 by dalin, griz: Update dependency version check for...
frjo’s picture

Unable to reproduce this but the "libraries (>=2.x)" format works equally well for me so committing.

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.