Flex Slider currently requires the Libraries API but relies on Drupal core's library handling abilities (hook_library() and drupal_add_library()).

Flex Slider should utilize the library handling capabilities provided by Libraries API in order to gain a number of benefits such as library version detection.

Files: 
CommentFileSizeAuthor
#2 use-libraries-api-1925590-2.patch3.86 KBDevin Carlson
FAILED: [[SimpleTest]]: [MySQL] 98 pass(es), 42 fail(s), and 0 exception(s).
[ View ]
#1 use-libraries-api-1925590-1.patch4.53 KBDevin Carlson
Test request sent.
[ View ]

Comments

Devin Carlson’s picture

Status:Active» Needs review
StatusFileSize
new4.53 KB
Test request sent.
[ View ]

A patch to use the library handling functionality provided by the Libraries API module.

Devin Carlson’s picture

StatusFileSize
new3.86 KB
FAILED: [[SimpleTest]]: [MySQL] 98 pass(es), 42 fail(s), and 0 exception(s).
[ View ]

Updated patch now that Views Slideshow integration is a separate project.

Devin Carlson’s picture

Status:Needs review» Fixed

Committed to 7.x-2.x.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

  • Commit 942210c on 7.x-2.x, youtube, 8.x-2.x, startslide by Devin Carlson:
    Issue #1925590 by Devin Carlson: Use Libraries API instead of core...