hello. After application to the job I get the following error:
PDOException: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '9-6-acl' for key 'PRIMARY': INSERT INTO {node_access} (nid, realm, gid, grant_view, grant_update, grant_delete) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3, :db_insert_placeholder_4, :db_insert_placeholder_5), (:db_insert_placeholder_6, :db_insert_placeholder_7, :db_insert_placeholder_8, :db_insert_placeholder_9, :db_insert_placeholder_10, :db_insert_placeholder_11), (:db_insert_placeholder_12, :db_insert_placeholder_13, :db_insert_placeholder_14, :db_insert_placeholder_15, :db_insert_placeholder_16, :db_insert_placeholder_17); Array ( [:db_insert_placeholder_0] => 9 [:db_insert_placeholder_1] => acl [:db_insert_placeholder_2] => 6 [:db_insert_placeholder_3] => 1 [:db_insert_placeholder_4] => 0 [:db_insert_placeholder_5] => 0 [:db_insert_placeholder_6] => 9 [:db_insert_placeholder_7] => content_access_rid [:db_insert_placeholder_8] => 30037204 [:db_insert_placeholder_9] => 1 [:db_insert_placeholder_10] => 0 [:db_insert_placeholder_11] => 0 [:db_insert_placeholder_12] => 9 [:db_insert_placeholder_13] => content_access_author [:db_insert_placeholder_14] => 15 [:db_insert_placeholder_15] => 1 [:db_insert_placeholder_16] => 0 [:db_insert_placeholder_17] => 0 ) w node_access_write_grants() (linia 3440 z /home/sylany/domains/sylany.hekko.pl/public_html/modules/node/node.module
please help me...


mh86’s picture

Status:Active» Fixed

Seems like the following core patch is not applied: http://drupal.org/node/1146244#comment-6644078

This patch is included in the make file and should automatically be applied, if you download the full package or correctly build the distribution.

sylany’s picture

ok, thx, it's work..

oglok’s picture

This patch is for GIT... can I apply the patch normally? (patch -p1 < file.patch)???

dasjo’s picture

oglok - sure, git apply and patch -p1 both work. see http://drupal.org/patch/apply

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

jas.yayas’s picture

please help me to fix the same issue. when i tried for patching, its not working, which file i need to patch.

I am new in patching.

what i did is, I logged in to server using ssh,
root@server [/home/job/public_html]# patch < 1146244-82-node-save-on-insert.patch
can't find file to patch at input line 5
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
|diff --git a/modules/node/node.module b/modules/node/node.module
|index f181b52..3096499 100644
|--- a/modules/node/node.module
|+++ b/modules/node/node.module
File to patch:
which file i need to select, please help


jas.yayas’s picture

please some body help me to patch