When upgrading you have to enable the Libraries module of version 2 or greater before updating the MailChimp code.

Should perhaps add this to the Release Notes?


brunorios1’s picture

i can confirm this...

i was using 7.x-1.0 and getting this error in apache log:

PHP Fatal error: Call to undefined function libraries_load() in /mysite/sites/all/modules/mailchimp/mailchimp.module$

levelos’s picture

Status: Active » Closed (works as designed)

7.x-2.8 and greater depend on libraries 2.0, as indicated in the .info file.

fonant’s picture

The problem is that while the .info file works for a new installation, an upgrade doesn't make use of the dependency information.

Ideally this new dependency should have been highlighted in the Release Notes, or a check added to the .install file's upgrade code. But hopefully people will find this, as it's an easy fix to upgrade libraries.

Thanks for the work on the module :)

J. Cohen’s picture

I've run into this on two sites. Is there any way to have the module check for the dependency on update? (e.g., drush up)

J. Cohen’s picture

Issue summary: View changes

Added comment about Release notes

bradspry’s picture

Issue summary: View changes
drush dl libraries --select

Choose one of the available releases for libraries:
 [0]  :  Cancel                                                 
 [1]  :  7.x-3.x-dev  -  2014-Feb-09  -  Supported, Development 
 [2]  :  7.x-2.2      -  2014-Feb-09  -  Supported, Recommended 
 [3]  :  7.x-2.x-dev  -  2014-Feb-09  -  Development            
 [4]  :  7.x-1.x-dev  -  2013-Oct-31  -  Development            
 [5]  :  7.x-1.0      -  2011-Jan-27  -  Supported, Installed