1) I was using 7.x-1.0-beta4 which worked fine except for this issue: http://drupal.org/node/1239946
2) I upgraded to 7.x-1.0-beta5 and got WSOD when viewing any node with a field collection, although I was able to edit the nodes OK. (i.e. I could go into "edit" and view the submit form, but not save the changes)
3) I installed 7.x-1.0-beta4+11-dev which I had working on another site (I installed this version to solve the issue mentioned in point 1) but this time when trying to submit edits to a node I got "The website encountered an unexpected error. Please try again later" - but I could view the node OK this time.
4) I reverted to 7.x-1.0-beta4 but on running the update script I got "Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 30720 bytes) in /modules/system/system.admin.inc on line 2078". After a few tries I got out of that, and now I can view and edit nodes OK but when submitting my changes I get "The website encountered an unexpected error. Please try again later."
5) all of this happens only to nodes with field collections
6) I cleared cache several times and did run the update script between each successive update of the module
7) possibly worth noting that when editing the nodes, I was sometimes deleting the extra empty field collection that the system added automatically before saving the node, but even when I left the empty field collection in place and then saved I got the same results.
8) if I now try and add a whole new node with a field collection I get "The website encountered an unexpected error. Please try again later." and on checking back under /admin/content the node has not been saved.
9) I am using Entity API 7.x-1.0-rc3


apmsooner’s picture

Status:Active» Needs review

I had similar errors.... update your entity to latest version and i think that will fix it for you.

thoughtcat’s picture

Done! It's fine now, cheers :) It's always the thing you think of last, isn't it... ;-)

Note: I got this message after running the update script: "Warning: array_keys() expects parameter 1 to be array, null given in drupal_schema_fields_sql() (line 6899 of /includes/common.inc)." - not seen that before.

I also got some "allowed memory size exhausted" fatal errors when running the update script for both Entity APi and FC but I guess that's to do with my more general php setup or something?

apmsooner’s picture

Status:Needs review» Closed (works as designed)

Not sure about those errors but may be related to something else you have installed. I'll close this issue for you anyhow since you got it resolved.

federico.parra’s picture

Hi. I'm experiencing the same symptoms that thoughtcat described,
and updating to the last version and even the last dev of Entity API
did not resolve the problem in my case.

Thank you for looking at this,

federico.parra’s picture

Status:Closed (works as designed)» Active
wizonesolutions’s picture

federico.parra: 1) Did you run update.php, and 2) clear the cache, and 3) if that did not help, have you tried the -dev version of Field Collection? (back up your DB first)

federico.parra’s picture

Hi wizonesolutions:
Yes, I did 1), 2) and 3). None of that helped.
I also installed dev version of Entity API just to try and it didn't help either.
thanks for the help!

wipeout_dude’s picture

I have the same issue.. After upgrading to beta5 I can no longer save nodes with field collections.. I have tried rolling back the module to beta4 but still cant save nodes..

Using Drupal 7.18 and Entity API 7.x-1.0.

Any suggestions?

wipeout_dude’s picture

I have been doing some digging and have logged what I have found so far here.. http://drupal.org/node/1877800

Not fixed yet because I am not a coder so not sure how but hopefully this helps get to a solution to fix this..

ronan.orb’s picture

Hmm ..I experienced also something. The db update itself took about 15 minutes. We have 3 field collections in place with ca. 25.000 entities.

After that I could not access a node view anymore. It also ended with the mentioned db error after the update script. So atm I'll do a rollback to beta4. Luckyly I have an old dump to use.

I'm on windows / xampp / 1.7.x / php 5.3

federico.parra’s picture

Anyone? I have not been able to use my site almost at all since the upgrade to Beta 5. Please, repair if possible!

wipeout_dude’s picture

Roll back to beta4..

See this thread.. http://drupal.org/node/1877800#comment-6900826

federico.parra’s picture

Hi, I tried to roll back to Beta 4 following the guidelines in that thread,
though field collections is still not working well, these errors come up when
I try to delete an item in a field collection:

PDOException: SQLSTATE[HY000]: General error: 1364 Field 'field_weekly_checklist_revision_id' doesn't have a default value: INSERT INTO {field_data_field_weekly_checklist} (entity_type, entity_id, revision_id, bundle, delta, language, field_weekly_checklist_value) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3, :db_insert_placeholder_4, :db_insert_placeholder_5, :db_insert_placeholder_6), (:db_insert_placeholder_7, :db_insert_placeholder_8, :db_insert_placeholder_9, :db_insert_placeholder_10, :db_insert_placeholder_11, :db_insert_placeholder_12, :db_insert_placeholder_13), (:db_insert_placeholder_14, :db_insert_placeholder_15, :db_insert_placeholder_16, :db_insert_placeholder_17, :db_insert_placeholder_18, :db_insert_placeholder_19, :db_insert_placeholder_20), (:db_insert_placeholder_21, :db_insert_placeholder_22, :db_insert_placeholder_23, :db_insert_placeholder_24, :db_insert_placeholder_25, :db_insert_placeholder_26, :db_insert_placeholder_27), (:db_insert_placeholder_28, :db_insert_placeholder_29, :db_insert_placeholder_30, :db_insert_placeholder_31, :db_insert_placeholder_32, :db_insert_placeholder_33, :db_insert_placeholder_34), (:db_insert_placeholder_35, :db_insert_placeholder_36, :db_insert_placeholder_37, :db_insert_placeholder_38, :db_insert_placeholder_39, :db_insert_placeholder_40, :db_insert_placeholder_41), (:db_insert_placeholder_42, :db_insert_placeholder_43, :db_insert_placeholder_44, :db_insert_placeholder_45, :db_insert_placeholder_46, :db_insert_placeholder_47, :db_insert_placeholder_48); Array ( [:db_insert_placeholder_0] => node [:db_insert_placeholder_1] => 8 [:db_insert_placeholder_2] => 243 [:db_insert_placeholder_3] => circle [:db_insert_placeholder_4] => 0 [:db_insert_placeholder_5] => und [:db_insert_placeholder_6] => 58 [:db_insert_placeholder_7] => node [:db_insert_placeholder_8] => 8 [:db_insert_placeholder_9] => 243 [:db_insert_placeholder_10] => circle [:db_insert_placeholder_11] => 1 [:db_insert_placeholder_12] => und [:db_insert_placeholder_13] => 59 [:db_insert_placeholder_14] => node [:db_insert_placeholder_15] => 8 [:db_insert_placeholder_16] => 243 [:db_insert_placeholder_17] => circle [:db_insert_placeholder_18] => 2 [:db_insert_placeholder_19] => und [:db_insert_placeholder_20] => 61 [:db_insert_placeholder_21] => node [:db_insert_placeholder_22] => 8 [:db_insert_placeholder_23] => 243 [:db_insert_placeholder_24] => circle [:db_insert_placeholder_25] => 3 [:db_insert_placeholder_26] => und [:db_insert_placeholder_27] => 62 [:db_insert_placeholder_28] => node [:db_insert_placeholder_29] => 8 [:db_insert_placeholder_30] => 243 [:db_insert_placeholder_31] => circle [:db_insert_placeholder_32] => 4 [:db_insert_placeholder_33] => und [:db_insert_placeholder_34] => 63 [:db_insert_placeholder_35] => node [:db_insert_placeholder_36] => 8 [:db_insert_placeholder_37] => 243 [:db_insert_placeholder_38] => circle [:db_insert_placeholder_39] => 5 [:db_insert_placeholder_40] => und [:db_insert_placeholder_41] => 64 [:db_insert_placeholder_42] => node [:db_insert_placeholder_43] => 8 [:db_insert_placeholder_44] => 243 [:db_insert_placeholder_45] => circle [:db_insert_placeholder_46] => 6 [:db_insert_placeholder_47] => und [:db_insert_placeholder_48] => 65 ) in field_sql_storage_field_storage_write() (line 448 of /srv/bindings/e49d00280243440ba70fa2bf8e2e6208/code/modules/field/modules/field_sql_storage/field_sql_storage.module).

federico.parra’s picture

Priority:Normal» Critical
Status:Active» Needs work

Please, help?

kevinquillen’s picture

I am receiving the same errors as #13 with the latest release of FC and EntityAPI.

kevinquillen’s picture

federico.parra’s picture

Please! somebody? My website is still broken since updating to FC beta 5. Even after the patches http://drupal.org/node/1877800#comment-7063936
it is having the same problems, as in http://drupal.org/node/1876624#comment-6896724

Thank you!

HitmanInWis’s picture

For those experiencing the WSOD issue mentioned in the original post, I can confirm that upgrading the entity module from 7.x-1.0-rc3 to 7.x-1.1 made the issue go away.

mike.davis’s picture

I was having this same issue and I can confirm that upgrading the entity module from 7.x-1.0-rc3 to 7.x-1.2 has fixed this issue for me.

bdanin’s picture

Issue summary:View changes
Status:Needs work» Closed (fixed)

sounds like this is fixed, should be closed

arlingtonvoicellc’s picture

Not fixed. Same issue. Currently using the most up-to-date version of entity 7-1.5. Gives me WSOD on save node.

arlingtonvoicellc’s picture

Status:Closed (fixed)» Active
jmuzz’s picture

Status:Active» Postponed (maintainer needs more info)

Does this affect the latest version? If so please post the error message and backtrace, it should be getting output to your web server error log when the WSOD happens.

jmuzz’s picture

Status:Postponed (maintainer needs more info)» Closed (cannot reproduce)