When the plugin system first went in, we converted aggregator.module as an example, and decided that the FetcherManager class should be in
Views currently has some manager classes in
Drupal\views\Plugin\Type\, but in other issues, tim.plunkett indicated a willingness to move them up a level.
Field currently provides several supporting classes for formatters and widgets, and so provides a subnamespace for each:
Do we want to standardize on whether to:
- always use Type,
- never use Type,
- or only use Type when wanting to have subnamespaces within it?