On my drupal 7 website i currently use the Libraries API module 7.x-1.0
How can I update to Libraries API version 7.x-2.0?

The 7.x-1.0 version is already use on my website and the box can not be deactivated...
What should I do to update to 7.x-2.0?


tstoeckler’s picture

Hi there.
You'll need to give a little more information before I/we can seriously help you with your problem.

I am assuming the following:
- You have installed Libraries API 1.0.
- Another module you have installed depends on Libraries API so that you cannot disable Libraries API.

The first question is: Why do you want to update? There is a small API change between 1.0 and 2.0 so will want to make sure that the depending module is compatible with the upgrade. If so, you should be able to update Libraries API with no problems. To be extra safe you could disable all dependent modules first, but that shouldn't be necessary. Don't forget to run update.php, though!!! Otherwise you will break your site.

Bernsch’s picture

OK, i will update the colorbox module to from version 1.x to 2.x.
And the colorbox module needs libraries 2.x
The libraries 1.x on my site currently required by Views Slideshow: Cycle

I'll try as:
1. disable Views Slideshow:Cycle
2. disable libraries API 1.0
3. uninstall Views Slideshow:Cycle
4. uninstall libraries API 1.0
5. install libraries API 2.0
6. install Views Slideshow:Cycle
7. uninstall colorbox 1.x
8. install colorbox 2.x

tstoeckler’s picture

Status: Active » Fixed

I don't even think you will have to uninstall, but...
Marking fixed for now. If there's anything left to do/discuss here, please re-open.

durum’s picture

Hi fellas.

This issue kept me busy for a while. Searching didn't give anything. I have read all the documentation just in case, so that I wasn't missing something. Then it was there on the first line of issues list. So, sharing my experience for the sake of search engines.

As soon as I observed, Services 3.1 uses Libraries 1.x where Services 3.2 breaks the site with Libraries 1.x and you get a wsod. Upon printing the errors on the screen (see here) I got the error:

Fatal error: Call to undefined function libraries_load() in .../rest_server.module line ...

Rather than uninstalling this and all dependant modules, as tstoeckler suggested, disabling Libraries and dependant modules, then replacing Libraries module folder with the new one, and then running updates fixed it in my case.

Maybe you should put a little note on the module page.


Bernsch’s picture

OK, i upload the libraries (2.x) folder with FTP in /sites/all/modules and overriede the libraries (1.x) folder on my server.
After this i run update.php
That's all you have to do to perform an update from 1.x to 2.x
It works

tstoeckler’s picture

Glad you guys could fix your problems. Is there anything specific we should be documenting that we currently aren't? Basically this is the normal procedure for upgrading modules that other modules depend on. The fact that you get a WSOD is, of course, quite unfortunate.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

derrickhawkins’s picture

okay, I know this topic is closed but I am having the same issue with colorbox (openenterprise distribution). after following the instructions carefully (several times) I keep seeing that Drupal (7.22) is still using Libraries 7.x-1.0. Where exactly do I go to update this to the latest library? I tried the sites/all/modules directory but that seems to have no affect as does the sites/all/libraries folder. Yes, I did ran the update.php but it tells me there are no updates to process.

Andre-B’s picture

just ran into this error after deploying to a new system - I, for whatever reason, have a libraries_old folder in my sites/all/modules I guess the update program dropped it there for backups sake. simple solution:

  1. comment out the line that calls the wrong libraries function in the current active libraries module
  2. disable the libraries module and do a uninstall
  3. delete the old folder
  4. clear cache
  5. enable the new libraries module and reactive prior disabled modules

I am not sure if you have to follow this procedure or if you can just delete the old libraries folder though

samantha1126’s picture

I have this same issue.

I need to update the libraries module from version 7.x-1.0 to the 7.x-2.0. The module i'm trying to install, JuiceBox (for a gallery) requires Libraries version 7.x-2.0 to run. When i click on the update tab to try and update the Libraries module, it isn't on this list.

I tried uninstalling the version 7.x-1.0 Libraries module but it just shows back up on the uninstall list after it says that it's uninstalled successfully. Because the Libraries module is not the updated version 7.x-2.0 JuiceBox module doesn't have an enable button next to and it says "incompatible with version 7.x-1.0".

How do i update the Libraries API module from 1.0 to the 2.0 version even when it's not showing up under the "Update" modules tab??

amibe’s picture

Issue summary: View changes

Drupal does not recognise the new library.

These are the steps I followed:

  1. Disabled all modules depending on Libraries
  2. Disabled Libraries
  3. Overwrote /sites/all/modules/libraries/ with version 2.0
  4. Ran Update

The update reports that there's nothing to update but Libraries is still listed as the earlier version.

Can I manually tell Drupal the new version so that the modules needing version 2.0 will become available?