After enabling the Media module (and using it to successfully import and browse media), this message is continuously displayed:

Media module install is not complete. Finish the install.

Following the 'Finish the install' link to here /admin/config/media/rebuild_types and pressing the 'Confirm' button to 'Update types for existing files', results in this Drupal error message:

No active batch.


juliavdw’s picture

I am seeing this same behavior. It is occurring on the remote server, but not on my local. It does not seem to be preventing the site from functioning but it would be nice to get rid of that notice, and be confident that media module is fully ready for use.

LTech’s picture

I can't install the module and get 'no active batch' error when I try and install it

LTech’s picture

I uninstalled 'secure pages' module and media worked fine.

joshua.albert’s picture

Issue summary:View changes

I'm getting the same thing, but when I press "Updated types for existing files", rather than display "No active batch", I'm getting a PDOException, saying there are missing tables. I tried to uninstall and re-install, but I received another PDOException, - "[db_name].image_dimensions doesn't exist".

Edit: Looks like this particular error, in my case, has to do with the File Entity module (

steinmb’s picture

Status:Active» Fixed

I suggest we close this issue. It is old and I see nothing in there that not have been addressed/fixed in other issues.

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.