It seems to me that instead of

config
-- active_[hash]
-- staging_[hash]

We could just do

config_[hash]
-- active
-- staging

This would make the docs a lot easier to write, would be a bit more clear, and would potentially make synching between sites somewhat easier. From a security standpoint I don't see any difference between the two.

Files: 
CommentFileSizeAuthor
#3 1821172-hash_directory_name.3.patch1001 bytesspearhead93
PASSED: [[SimpleTest]]: [MySQL] 46,242 pass(es). View

Comments

heyrocker’s picture

Component: image system » configuration system
beejeebus’s picture

Assigned: Unassigned » beejeebus

i'll work on this.

spearhead93’s picture

FileSize
1001 bytes
PASSED: [[SimpleTest]]: [MySQL] 46,242 pass(es). View

I've just moved the hash on the path creation.

alexpott’s picture

Status: Active » Reviewed & tested by the community

Tested locally. Looks good. Thanks for the work.

webchick’s picture

Status: Reviewed & tested by the community » Fixed

Lovely! This was uncovered as a "UX" problem (uh. 'Deployment Experience?') in #1697256-85: Create a UI for importing new configuration, and the end result is you now only have to keep track of two silly-ly named directories instead of 4 (or 6 or...) to do the standard recommended dev => prod deployment workflow.

Committed and pushed to 8.x.

Automatically closed -- issue fixed for 2 weeks with no activity.