PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'read_only' in 'field list': SELECT rid, read_only FROM {chatroom_role} WHERE cid = :cid; Array ( [:cid] => 2 ) in Chatroom->loadAllowedRoles() (line 91 of /home/example/public_html/sites/all/modules/chatroom/chatroom.chatroom.inc).
At least one similar error has been reported for this module. I want to add that this is the error I get when I click on the Main Menu tab of the chat room. It is also the error I get when I try to access the site's Content.
I cannot access the site's content to delete the chat room content. I cannot disable the module even after I delete the chatroom tables in the database.
Even when manually removing the field_chatroom from the content type and then from the field list, I still cannot deactivate the module and see the follwing message next to it: Required by: Drupal (Field type(s) in use (no link to field list anymore.)
Once I have deleted the field, I gain access to the Content list and can delete the Chat room content.
Depite the field, content, and content type deleted, I still cannot deactivate the chatroom module as it still claims Required by: Drupal (Field type(s) in use.
Any other suggestion to completely remove the module and try re-installing it?
Any help greatly appreciated. Thank you.


beejeebus’s picture

Version:7.x-2.0-alpha2» 7.x-2.x-dev

try updating to the latest code?

Triumphent’s picture

No. What I have done thus far is change the status of chatroom in the database from 1 to 0 in the system table. I was then able to uninstall it normally. I am now monitoring the site for any unexpected error. I will try again re-installation with the latest code in 4-5 days. Thanks.

beejeebus’s picture

Status:Active» Postponed (maintainer needs more info)
Triumphent’s picture

I am being told that this is a new feature in Drupal core. That it is necessary to have a cron run to completely remove the field before being able to disable the module. The only problem is that it doesn't work....! lol

Triumphent’s picture

Yes, it's a core bug that they've been working on for two years and have declared as "fixed" for lack of interest..!

beejeebus’s picture

sorry dodgy alpha chatroom code made you hit that.

i've updated the chatroom project page to point out that the code is still not trustworthy.

Gergely Lekli’s picture

Issue summary:View changes
Status:Postponed (maintainer needs more info)» Closed (fixed)

This does not seem relevant any more.