• Advisory ID: SA-CONTRIB-2012-110
  • Project: Colorbox Node (third-party module)
  • Version: 7.x
  • Date: 2012-July-11
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting

Description

Colorbox Node gives the user the ability to display ANY page inside a colorbox modal without the header and footer. The module accepts some settings from URL parameters and didn't sufficiently validate them before printing them to the browser, allowing malicious users to inject script code into the page.

CVE: CVE-2012-4474

Versions affected

  • Colorbox Node 7.x-2.x versions prior to 7.x-2.2.

Drupal core is not affected. If you do not use the contributed Colorbox Node module, there is nothing you need to do.

Solution

Install the latest version:

Also see the Colorbox Node project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.