Hi thanks for open enterprise.. trying to work through it all ;
Trying to customize the contact form - have display suite installed and reviewed the video here: http://youtu.be/rSgd91tZSEc on "Renderable Elements, Fieldgroups and Display Suites"

at about 8:22 in the video begins discussing enabling customization of the contact form - installed renderable elements using drush. At point 8:40 in the video .. 'click manage display on the contact form" at point 8:57 the click through renders the standard page.. the OE install brought up a pop up window.. cycled through - then blew out the site entirely.

"Server Error" : HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

running status in drush produces the message:

Drush command terminated abnormally due to an unrecoverable error. [error]
Error: Unsupported operand types in /profiles/openenterprise/modules/entity/includes/entity.property.inc, line 86

In trying to disable the rel module ( renderable elements) - I receive the same message.

Line 86 in the entity.property.inc is contained within the function entity_get_all_property_info($entity_type = NULL)
at the point where it Add all bundle properties
foreach ($info['bundles'] as $bundle => $bundle_info) {

function entity_get_all_property_info($entity_type = NULL) {
  if (!isset($entity_type)) {
    // Retrieve all known properties.
    $properties = array();
    foreach (entity_get_info() as $entity_type => $info) {
      $properties += entity_get_all_property_info($entity_type);
    return $properties;
  // Else retrieve the properties of the given entity type only.
  $info = entity_get_property_info($entity_type);
  $info += array('properties' => array(), 'bundles' => array());
  // Add all bundle properties.
<strong> foreach ($info['bundles'] as $bundle => $bundle_info) {</strong>
    $bundle_info += array('properties' => array());
    $info['properties'] += $bundle_info['properties'];
  return $info['properties'];

Can you help me get my environment back?
At this point I'm flummoxed as what to do now..
thank you for your help...


jackhutton’s picture

I'm running in a local Mamp Mac environment...

jackhutton’s picture

I see this from the commerce module: http://drupal.org/node/1528136 entity_load('commerce_order') gives a fatal error

jackhutton’s picture

decided to edit the database directly.. manually.

Went into the system table, disabled renderable elements module
cleared out the table ren_build
cleared the cache tables manually

ran a drush status and it rendered.

bringing the site up had menu error: and this message error: Warning: require_once(/Users/jack/foo/sead/d7_oe/sites/all/modules/rel/rel.admin.inc) [function.require-once]: failed to open stream: No such file or directory in menu_execute_active_handler() (line 514 of /mysite/includes/menu.inc)
searched for rel.admin.inc and found 2 records which I deleted..
and its back up.
some minor css wonkiness .. guess cause of something I deleted..but that I can deal with..


so. still interested in what caused that initial error message.. it would be nice to be able to use renderable elements as the display suite module can.. but openenterprise doesn't play well w. renderable elements..

.. feedback alway appreciated..