simplenews.module currently starts like this:
* @defgroup simplenews
* Enable nodes to be used as newsletter, manage subscriptions and sent
* email newsletter to subscribers.
* Simplenews node handling, sent email, newsletter block and general hooks
* @ingroup simplenews
* @todo Where possible build re-usable functions wrapped around database calls.
* @todo Consider context support for t():
* @todo Coding standards: type hinting
* @todo Implement hook_requirements()?;
* @todo Separate token function into simplenews.tokens.inc
* @todo Consider using hook_hook_info() to move hooks out of .module.
The initial @defgroup is not necessary. As for the @todo's:
- Check if there are remaining direct db_* uses in non API functions like forms, page callbacks and hook implementations. Check if we can move them into API functions.
- Haven't seen a need for t() context, remove that
- Coding standards have been cleaned up, type hinting doesn't make much sense until we have entity classes, remove.
- I don't know what we could possibly check in hook_requirements(), remove.
- Moving the token hooks makese sense.
- hook_hook_info() doesn't help us, we can only do it for our own hooks. Remove.