• Advisory ID: DRUPAL-SA-CONTRIB-2012-060
  • Project: Commerce Reorder (third-party module)
  • Version: 7.x
  • Date: 2012-April-18
  • Security risk: Not critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Request Forgery


CVE: CVE-2012-2116

The Commerce Reorder module enables you to reorder previously purchased products for Drupal Commerce.

The module does not sufficiently protect the re-order URL against Cross Site Request Forgery (CSRF), allowing a malicious user to trick someone into adding unwanted items to their shopping cart.

This vulnerability is mitigated by by the fact that while items can be placed in a shopping cart, the user still has to complete the checkout process, and by the fact that re-ordering is restricted by access to the "source" order.

Versions affected

  • Commerce Reorder versions prior to 7.x-1.1.

Drupal core is not affected. If you do not use the contributed Commerce Reorder module, there is nothing you need to do.


Install the latest version:

Also see the Commerce Reorder project page.

Reported by

  • Ivo Van Geertruyen (mr.baileys) of the Drupal Security Team

Fixed by

  • Pedro Cambra (pcambra), the module maintainer
  • Ivo Van Geertruyen (mr.baileys) of the Drupal Security Team

Coordinated by

  • Ivo Van Geertruyen (mr.baileys) of the Drupal Security Team

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.