Title says it all, here is a screencast http://screencast-o-matic.com/watch/cleY3lBsh


bryancasler’s picture

I've gotten the crop to work a on a few occasions, but i'm unable to reproduce the steps. I think re-saving my "File type displays" may have helped. What I noticed is that if I successfully get a crop, I will not be able to crop that same image a second time. I have to remove the image completely and re-add it. Might just be a problem with the crop not getting saved.

Matthijs’s picture

Title:Cropping on a "Media file selector" widget does not work» Support for the "Media file selector" widget
Assigned:Unassigned» Matthijs
Category:bug» feature

I'm still working on Media integration (see #1367782: Media 2.x integration) and haven't tested Manual Crop trough widget, only on the file management page. But thanks for letting me know, I'll be looking in to that.

bryancasler’s picture

Thanks for the responsiveness Matthijs,

I was able to reproduce how to successfully crop an image as well as identify some hanging points in the cropping process.

Here is another short screencast going over the process http://screencast-o-matic.com/watch/clerFrB9G

Matthijs’s picture

Hi there,

Thanks for the screencast. As said before Media integration is still in progress, so as you noted there's still work to do. Have you ever tried the original Manual Crop widget? This one shows how it should be and - hopefully - also will be for the Media module widget after the integration has been finished ;-)

bryancasler’s picture

I haven't Matthijs, I'm actually looking for a media solution and was directed to this module from this thread #1491508: A call for consolidating efforts. The path to a media integrated D7 cropping module..

One of the maintainers of the "Image javascript crop" module said that their module is basically abandoned and suggest I look at yours. Just hoping to contribute what I can :)

Matthijs’s picture

Status:Active» Fixed

I just pushed some minor changes, the media selector widget seems to be working now (tested with the latest 7.x-2.0-dev version of the Media module).

Could you give it a try? Sorry for the long wait.

bryancasler’s picture

Just pulled the current commit. Testing now.

bryancasler’s picture

Works great! I can't thank you enough.

Just running into this problem now #1499222: Image not flushed when image_path_flush is called.

Matthijs’s picture

Status:Fixed» Closed (fixed)

I'm glad I could help :-)

firfin’s picture

Issue summary:View changes

For future referents. This doesn't seem to be in a release version yet? Just in the dev version.