I have installed filedepot on a drupal 7 site. I am unable to get the user interface to show up. When i select the filedepot from the navigation menu it will go to the page and says filedepot at the top. However no user interface shows up as shown in the thumbnain on the main page of the filedepot site. I have tried it using ie, firefox, and chrome. Thank you in advance for your assistance.


rcn01’s picture

Category:bug» support
nick_t’s picture

Subscribing. I'm seeing the same.

blainelang’s picture

Assuming you have reviewed the module requirements then we will need more informatioin. Install firebug if your using firefox or use your browser javascript console to identify the details of the javascript error from the AJAX request to load the filedepot page.

djg_tram’s picture

Warning: file_get_contents(sites/all/libraries/jquery.blockui.js)
Warning: file_get_contents(sites/all/libraries/html_encoder.js)

The README (that nobody reads) lists them but a more informative error message could be more comfortable... :-)

narenpg’s picture

new37.54 KB

subscribing. I`m seeing the same. I have posted this on other forum

I have the yui build which is 2.7.0.. This is what i have in my filedepot base setup settings.

Also renamed yui folder to yui_2.7.0 as listed in the README.


Seeing errors in apache error logs

[Mon Mar 05 09:58:14 2012] [error] [client] File does not exist: /var/www/html/sites, referer: https://www.example.com/bar/filedepot

Note: clean urls is turned on.

I was able to hit manually the files under yui/build directory. I have installed jquery and encoder javascript under libraries. I have also copied the filedepot folder under bar/sites/filedepot. Now the filedepot exists under modules and also under sites directory. I can read the file README.txt under sites/filedepot. I cannot understand why it says filedepot not found under sites directory.

I am logging in as admin which should eliminate permission issues. Attaching the firebug file.


_randy’s picture

Why did you add the extra path information to the YUI libraries?

Your post says you added the YUI libraries to:

you have sites/all/libraries in there twice.

It should just be

narenpg’s picture

narenpg’s picture

Hi _randy,

One quick question. As per README file

2) The filedepot module now requires the libraries module be installed.
We are not permitted to include NON-GPL or mixed license files in the module distribution as per Drupal guidelines.

You will now need to create a sites/all/libraries folder if you don't already have the libraries module installed.
PLEASE rename the files as noted below

The following three javascript and support files then need to be retrieved and saved to the sites/all/libraries folder.
> http://www.strictly-software.com/scripts/downloads/encoder.js - SAVE FILE as: html_encoder.js
> http://jquery.malsup.com/block/#download - SAVE FILE as jquery.blockui.js

I am trying to find which is the third javascript file. Maybe that is the one that is having problems.

Please let me know if you have any suggestions.


narenpg’s picture

new136.56 KB

Made little improvement.. I was able to get rid of yahoo namespace undefined error. That was due to the path. Now i need to fix the "jquery.blockui is not a function" error. This will fix the whole issue. I am clueless with this one.. If anyone has any info please let me know.

ls4680’s picture

I had the same problem. I finally figured out that when I pasted the files (jquery.blockui.js html_encoder.js) source code into my editor that my text editor wrapped the long lines which caused syntax errors.

Re-pasting the source into the editor using long lines (pico -w ) resolved the issue.

narenpg’s picture

hi ls4680,
Could you please attach the formatted file. I am still having issues.. Thanks.

blainelang’s picture

new9.36 KB

Attached is a zip file with the two JS library files - html_encoder.js and jquery_blockui.js. They should be copied to the sites/all/libraries directory.

narenpg’s picture

Thanks. No luck for me.. I copied(unzipped) to sites/all/libraries and gave 777 permissions and also restarted the webserver..

narenpg’s picture

Looks like it is not executing the javascript.

narenpg’s picture

Title:No User Interface» jquery.blockui script says it requires jQuery v1.2.3 or later

Maybe i am missing jQuery. is it a drupal module.. Can you please help me how to find out?

_timpatrick’s picture

Assigned:Unassigned» _timpatrick
Status:Active» Postponed (maintainer needs more info)

JQuery is a javascript library that comes bundled with drupal.
Can you try with the latest version of the libraries and this module?
Also some more information about your drupal install?

_timpatrick’s picture

Status:Postponed (maintainer needs more info)» Closed (cannot reproduce)