Hi I can't import a remote-server site to an Acquia Dev Desktop.

I have a copy of my remote server, files and folders from public_html and down.
I have a sql-backup file in the .sql format.


***************
STEP A)
***************

***************
In the "sites/" - I see two folders
all
default

and a example.settings.php file
***************
I went into the default-folder
There I find two files
- a default.settings.php I did'nt change.
- a settings.php file I did change
***************
I made the following changes to the settings.php file

At line
180 I deleted:
$databases = array (
'default' =>
array (
'default' =>
array (
'database' => 'theoriginaldbname,
'username' => 'theoriginaldbusername,
'password' => 'theoriginalpw',
'host' => 'localhost',
'port' => '',
'driver' => 'mysql',
'prefix' => 'dr_',
),
),
);

and wrote:

$databases = array ();
***************
at line 212 I emptied the salt:

$drupal_hash_salt = '3tcoaji3p3su96hefdfdfdfdfvg5d8exfqap2sr2im';

to

$drupal_hash_salt = '';
***************


***************
STEP B)
***************

At the end of the settings file I added

///////////////

////////////////////////////////////////////////////////
// Don't edit anything below this line! //
// This section is autogenerated by Acquia Dev Desktop Control Panel //
///////////////////////////////////////////////////////////////////////
//<@@ADCP_CONF@@>
$base_url = 'http://anewservername:8082';

//D6 DB config
$db_url = 'mysqli://theoriginaldbusername@127.0.0.1:33066/theoriginaldbname';

//D7 DB config
$db_prefix = 'dr_';
if( !isset($databases) )
$databases = array();
$databases['default']['default'] = array(
'driver' => 'mysql',
'database' => 'theoriginaldbname',
'username' => 'theoriginaldbusername',
'password' => 'theoriginalpw',
'host' => '127.0.0.1',
'prefix'=> 'dr_',
'port' => 33066 );
//

<
***************
STEP c)
***************

i click import in the Acquia Dev Desktop

I add following:

Code Base
site path: the path to the copied files from the server. They are in my pc and I point to
C:\A2\fd\public_html

Database : "I have a Mysql database dump for my site"

And i point to the dump file at my PC.

New DB name: I put in "theoriginaldbname" --------------- same as in the settings file
Server: "anewservername" --------------- not the same as in for the remote server
I go import. It goes well.
In Desktop phpMyAdmin I see the files. Good.

I click goto and get:

***************
STEP D)
***************

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table
'theoriginaldbname.semaphore' doesn't exist: SELECT expire, value FROM {semaphore} WHERE name = :name;
Array ( [:name] => variable_init ) in lock_may_be_available() (line 167 of C:\A2\fd\public_html\includes\lock.inc).

***************
STEP E)
***************
i read and tried to understand from to good info pages; even if they strangely differ in advice:
http://www.abipo.com/blog/web-design/cms/import-a-drupal-website-from-a-...

and
http://network.acquia.com/node/1718294


***************
STEP F)
***************

Any suggestions? Best regards/ Flingan

Comments

couturier’s picture

What exactly is your question? If you have a site that you want to use on Acquia Dev Desktop, just use the Backup and Migrate module to save a copy of your database in the current site, then copy the database contents to a new database that is connected to your copy of Dev Desktop. You will need to change the database information in settings.php manually using an editor like Komodo.

I realize you have already done most of these steps, so I do not understand your problem.

kopeboy’s picture

I've done that, but the problem is that you run out of memory

nericson’s picture

Acquia Dev Desktop is on Drupal 7.7 and you say your site is on Drupal 7.8. Perhaps that is the problem?

dfobox’s picture

I haven't edited the settings.php file, but I'm having the same error. Were you able to resolve it?

Christopher James Francis Rodgers’s picture

Drupal 7 - I downloaded existing online-webhost site
originally created/maintained by webhost's
free Control-Panel 'automated script service', SimpleScripts;

& Now I am trying to run it locally on my computer
using 'Acquia Dev Desktop'.

===

My [Solution]:

Add
'prefix' => 'dr_',
to settings.php

[1 Solution] Error: PDOException: SQLSTATE[42S02]: ... semaphore

 

"All the best; intended."
- Chris
___

Drupal 8 is great.

Re: Dupal 9,000
Three-minute Video on the problem
of technology out-pacing users.
http://great-grandma.com/gill_bates-dead_at_42/index.html