Just updated to 6.x-1.4, and started getting this error message. After reverting to 1.3, the error goes away.

Comments

jenlampton’s picture

Version: 6.x-1.4 » 6.x-1.x-dev

Can you updatet to the -dev branch and let me know if you are still encountering this error? The function was renamed in the D7 branch, it's possible something got misplaced. Also, in the future it would be useful to know the full error message (it probably contained a file and line number that would help me track it down).

jenlampton’s picture

Status: Active » Closed (cannot reproduce)

Please re-open this issue if the problem still exists for the dev version.

MacMladen’s picture

Issue summary: View changes
Status: Closed (cannot reproduce) » Active

I can confirm that it is still here, I was updating a site and tried versions 1.5 and 1.x-dev and both could not find _taxonomy_title_get_title().

However, returning to 1.3 enabled the site to function again.

The problem is in function name _taxonomy_title_get_title that is changed to _taxonomy_title_get

Version 1.3 at the end, line 135 in taxonomy_title.module

function _taxonomy_title_get_title($tid){
  $title = db_result(db_query("SELECT title FROM {taxonomy_title} WHERE tid = %d", $tid));
  return $title;
}

Version 1.5 line 136 around middle, in taxonomy_title.module

function _taxonomy_title_get($tid) {
  $title = db_result(db_query("SELECT title FROM {taxonomy_title} WHERE tid = %d", $tid));
  return taxonomy_title_tt("taxonomy_title:term:$tid:title", $title);
}

It may also seem that compatibility is broken as return seems to differ?

jenlampton’s picture

Status: Active » Closed (cannot reproduce)

Hi @MacMladen, and thanks for the help!

It shouldn't matter that the function name changed between versions. As long as there is nothing in the new version that calls the old function name, everything should work as intended. Did you remember to run update.php after replacing the module code? Or at least clear all the caches?

I'm going to mark this issue as closed (cannot reproduce) since there is no more development happening on the 6.x version. You will need to update to the 6.x-1.5 before upgrading from Drupal 6 to Drupal 7, and if we can confirm there is really a problem here I will be more than happy to take another look. Please paste in the full error message you see on the screen, and leave me a set of steps I can follow to reproduce the error.