Drupal 8.4.4 install, everything seems to be working fine, however I look at the Status Report, and I'm told I have 1 error. I look down the page a bit, and I see:


Not protected

The update.php script is accessible to everyone without authentication check, which is a security risk. You must change the $settings['update_free_access'] value in your settings.php back to FALSE.

OK, Fine. So I open up my editor, I open up SETTINGS.PHP, and I look through it and I find line 321 says, and I quote:

$settings['update_free_access'] = FALSE;

So, I change permissions to 777, I SAVE the SETTINGS.PHP file once again, I set permissions back to 444 I refresh my screen to make sure it has all gone through, I go back into Drupal, I clear my caches, I refresh my browser and... I still get the same error message. 

Am I missing something? Am I just stupid? Help.


VM’s picture

change default folder to 777

change settings.php to 777

edit settings.php (changes will now stick when saved)

save settings.php

reset perms on settings.php

reset perms on default folder.

VM’s picture