I am running a Drupal 8 multisite. All was well until I used Drush to update to the latest version and got a bootstrapping error.  

This is the latest error:

 /var/www/html/drupal/core/lib/Drupal/Component/DependencyInjection/Container.php(171): Drupal\Component\DependencyInjectio" while reading response header from upstream, client: 108.14.88.246, server: , request: "GET /favicon.ico HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "www.liftuganda.org", referrer: "http://www.liftuganda.org/"
 

Comments

VM’s picture

version of PHP in use? I ask because the error indicates PHP 5?

digitaldrz’s picture

This was set up on Digital Ocean automatically with an automated Drupal install.  I will check on DO about PHP.  The site was working until I updated to the latest version of Drupal.  Is the problem related to PHP??

VM’s picture

can't say for certain. notice PHP 5 in the error. Have you cleared database cache? I don't see very much about the error using google. This it's not widespread

What I do with an error when its unfamiliar is pick out clues and chase them down. What I pick out of the error is "fastcgi://unix:/var/run/php5-fpm.sock" <- see php5?

Drupal 8 required PHP 5.5.9 per https://www.drupal.org/docs/7/system-requirements/php

First thing I'd do, especially if they started immediately after an install (I can't tell from the limited information provided), is check to ensure environment can handle it. Just because its in their toolbox to use doesn't mean that you shouldn't proceed with caution. Also of note, I can't at all speak with a hosts 'one click installer method'. Thus, installing drupal from drupal.org may be worth the effort.

digitaldrz’s picture

I have a backup of the site that is not too old and was able to start it from that.  I will try to upgrade to Drupal 8.4 and see if the problem comes up again.  If not, fine.  If so, I have a starting point.