diff --git a/core/includes/bootstrap.inc b/core/includes/bootstrap.inc
index 6c8ee5e5f2..bd7d49ef8b 100644
--- a/core/includes/bootstrap.inc
+++ b/core/includes/bootstrap.inc
@@ -22,6 +22,11 @@
  */
 const DRUPAL_MINIMUM_PHP = '5.5.9';
 
+/**
+ * Minimum recommended version of PHP.
+ */
+const DRUPAL_RECOMMENDED_PHP = '7.1.0';
+
 /**
  * Minimum recommended value of PHP memory_limit.
  *
diff --git a/core/modules/system/system.install b/core/modules/system/system.install
index ce48afe725..289d13a76a 100644
--- a/core/modules/system/system.install
+++ b/core/modules/system/system.install
@@ -183,6 +183,10 @@ function system_requirements($phase) {
     // If PHP is old, it's not safe to continue with the requirements check.
     return $requirements;
   }
+  elseif (version_compare($phpversion, DRUPAL_RECOMMENDED_PHP) < 0) {
+    $requirements['php']['description'] = t('Your PHP installation is running version %version. It is recommended to upgrade to version %recommended or higherto ensure your site remains secure and continues to receive updates. See the <a href="http://php.net/supported-versions.php">PHP version support documentation</a> and the <a href=":php_requirements">PHP requirements handbook page</a> for more information.', ['%version' => $phpversion, '%recommended' => DRUPAL_RECOMMENDED_PHP, ':php_requirements']);
+    $requirements['php']['severity'] = REQUIREMENT_WARNING;
+  }
 
   // Suggest to update to at least 5.5.21 or 5.6.5 for disabling multiple
   // statements.
